Posts Tagged "nikon"

Sparkbooth DSLR

With latest update, Sparkbooth DSLR 5 now supports the Canon EOS T7i / 800D, 77D, 6D Mark II, and SL2.

Check Out Sparkbooth DSLR

Sparkbooth DSLR for Canon requires Windows 7 or newer. The latest version of Sparkbooth DSLR no longer supports Windows XP and Vista. If you have Windows XP or Vista, you can use the special version of Sparkbooth DSLR 4 which works for XP and Vista. This special version only supports Canon cameras up to T6i. If you have a newer Canon camera model, you will need to upgrade your operting system to Windows 7 or newer to use the latest Sparkbooth DSLR.

Download Sparkbooth DSLR 4 for Windows XP and Vista